通达信指标公式MACD绝杀指标公式源码

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL); OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0); OBV2:=EMA(OBV1,3)-MA(OBV1,9); OBV3:=EMA(IF(OBV2>0,OBV2,0),3); MAC3:=MA(C,3);

最后更新:2019-02-21

推荐指数★★★☆☆

大盘分析 在线预览
  • 网盘下载
  • 资源详情

    VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
    OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
    OBV2:=EMA(OBV1,3)-MA(OBV1,9);
    OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
    MAC3:=MA(C,3);
    SHORT:=12;LONG:=26;MID:=9;
    DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;
    DEA:EMA(DIF,MID)COLORFF9900 ;
    MACD:=(DIF-DEA)*2;
    STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;
    {持币:STICKLINE((SAR(10,2,20)>=H),MACD,0,1.5,0),COLORGREEN;
    持股:STICKLINE((SAR(10,2,20)<=L),0,MACD,1.5,0),COLORYELLOW;}
    吸:=XLPL.NOTEXT吸,COLORLIRED,CIRCLEDOT,LINETHICK3;
    拉:=XLPL.NOTEXT拉,COLORRED,CIRCLEDOT,LINETHICK3;
    派:=XLPL.NOTEXT派,COLORGREEN,CIRCLEDOT,LINETHICK3;
    落:=XLPL.NOTEXT落,COLORWHITE,CIRCLEDOT,LINETHICK3;
    STICKLINE(吸,0,MACD,1,0),COLORLIRED;
    STICKLINE(拉,0,MACD,1,0),COLORRED;
    STICKLINE(派,0,MACD,1,0),COLORGREEN;
    STICKLINE(落,0,MACD,1,0),COLORWHITE;
    入1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK1;
    入2:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLOR00FF00,LINETHICK1;
    【筹码峰%】:WINNER(CLOSE)*100,NODRAW,COLORWHITE;
    上涨家数:INDEXADV,NODRAW;
    下跌家数:INDEXDEC,NODRAW;

    很赞哦!()

    站点信息

    • 研报试用:QQ:2148132895
    • 文章统计:1233 篇
    • 源码统计:43 篇
    • 微信公众号:扫描二维码,关注我们